When technology attacks

When technology attacks

I am sitting here writing this blog post on my fresh new Vista x64 SP1 install, which was a debacle that took only 2 days to complete. I know you probably do not wish to be regaled with yet another tale of Vista install issues, but this is one that does an excellent job of construing the complexity that is modern technology and showing you that the old adage “the simplest explanation is the correct one” may not always be correct.

It all started a few months back when I purchased a new Dell M1530 laptop. I bought it with a tiny 5200rpm drive and 1GB of ram (which actually isn’t even an option anymore) and I installed a nice 200GB 7200rpm drive (with a 16MB cache) and 4GB of RAM. By the way, before you start screaming “Mr. Moneybags” the RAM was about 80 bucks and the harddrive was about 170 dollars. This stuff is so cheap these days it is embarrassing. I loved the laptop, it is quite fast (and I have had several people comment on how fast it is), but I always had one problem… the freakin’ thing ran as hot as the fires of Hades. The shell on it is all metal though, so I thought it was just acting like a giant heatsink. The key word here being “thought”.

Everything ran fine though, I had no other complaints or problems at all. So, yesterday Vista SP1 finally popped up on my Windows Updates list and so I decided to install. The install started running and went through its usually paces until it restarted and drops to a black screen where it starts copying files. The files were counting up higher and higher until I suddenly get an error that looked something like “!! 0x00000c2 !!” with the name of the file that it stopped on “ExplorerFrame.dll”. Great, I thought, SP1 hosed my system. I tried to reboot and it started through the process again, but it locked up again. By this time, with all of the file copying and hard drive activity my laptop was getting quite hot. I decided to go online and see if I could find anyone else having this issue. Well, I found quite a few people that were experiencing this problem. But the only solution was to do a restore back to the restore point that Vista SP1 creates.

So, I restarted my machine and went into the BIOS to configure it to boot from the DVD drive, and my laptop suddenly shut off. What? I rebooted and went back to the BIOS, this time successfully and then I popped in the Vista x64 DVD, booted up the computer and it started loading. But as soon as it finished loading and was supposed to pop into the Vista repair screen, my laptop turned off. What?

Yep, it just powered down. So I hit the power button to turn it back on and popped in the DVD and the same thing happened again. By this time though, the laptop was getting extremely hot. Why was it getting so hot? It wasn’t any more hot than I had ever felt before, but I thought that maybe inside Windows there is more cooling management features that run to keep the CPU from running too hot? (I don’t know, is there?) So, I decided to give my laptop a rest.

I let it rest for about an hour and I came back and booted the restore DVD and it worked. I got to the restore prompt, began running the restore and it locked up about 10 minutes into it. I let it run for about 30 minutes and suddenly the laptop cut off. How was I going to get my laptop restored? And these shutoffs looked exactly like it was an overheating issue, but I had never had any problems before. Well, I decided to go ahead and go the nuclear route first, and just restore from my backups (yes, I run Acronis TrueImage regularly. I am a paranoid person and it has *always* paid off). But I bet you can guess what happened next. First I had to install the latest version of TrueImage on another machine, since my laptop was the only one running version 11, so that I could create the restore media. Then I had to burn a cd and boot from it on my laptop. I completed this cycle only to have my laptop cut off on me right in the middle of my restore.

Okay, so now I had a totally hosed hard drive since it was half restored. I was now starting to worry a bit, but I decided that my laptop was just getting too freaking hot and it didn’t look to me like the fan was coming on at all. So I went ahead and flipped my laptop over and do some surgery. (If you are from Dell, you can stop reading now) I popped off the cover where the RAM is, since that also exposes the CPU, Graphics card, and heatsink fan. I followed the wire from the heatsink and it went down the side of the fan casing and followed a copper tube that went from the CPU over to the GPU (or it could be the motherboard chipset). There were three different chips that this copped tube went over.

I followed the wires and I couldn’t really see where they went, but then I saw what looked like a tiny fan connector with nothing plugged into it. I poked around under the copper tube and out popped a fan connected. Wow. The fan on my CPU had never been plugged in. I guess that is a testament to the heat management that is put into laptops these days, but I was a bit pissed off, because I’m sure that this has now shortened the life of my laptop. The only thing I can guess is that while running in windows that the CPU is slowed down or something to compensate for the heat. Not to mention the fact that I rarely use my laptop for periods of longer than a few hours. But I had seriously been running this thing with absolutely no active cooling for several months now, unbelievable.

I plugged the fan in and turned my laptop back on. I started up the Acronis recovery (which took about an hour) and halfway through the difference was stark. My laptop had been doing continuous file copying and processing for 30 minutes and it was barely warm (I could also now hear the very low hum of the fan). Well, I completed my restore, and I thought that maybe the Vista SP1 upgrade had failed because the laptop had overheated, so I decided to go ahead and run it again. I did a full backup first though, just to be safe.

Of course that wasn’t my problem, it locked up again. So I went ahead and recovered my hard drive again. What was I going to do? I am not going to have Vista reminding me every 4 hours that I have updates which I am unable to install. That would drive me insane. But at the same time I don’t want to set the updates to be ignored, because after a service pack is released I believe that updates for pre service pack installs stop. Not to mention that there are some important updates in SP1 that I want!

My next thought was that maybe something was screwed up on my hard drive. I had after all been running my laptop for several months under conditions that simulated the bottom of an active volcano. It wasn’t out of the realm of reality that my hard drive had begun to fail. So I ran chkdsk and amazingly it found an error in the NTFS indexes on the exact file that my SP1 install was locking up on! So, I ran “chkdsk /F”,  rebooted and let it try to fix all my problems.

I then rebooted one last time into Windows, crossed my fingers, and ran the SP1 update one last time. And, as we both know, it succeeded. Otherwise you would not be getting this post right now and my wife would be getting a migraine. So, let this be a lesson to all those out there, before you start blaming Vista, OS-X, Linux, or whatever for your problems…it may not be quite that simple.

Oh, and Microsoft, why don’t you just force a chkdsk run *before* you install a service pack? The SP already takes forever to install, what is an additional 20 minutes?

Loved the article? Hated it? Didn’t even read it?

We’d love to hear from you.

Reach Out

Comments (2)

  1. Sounds like a problem I had a couple months back. I sent my Inspiron e1705 laptop back to them a few months ago to have the motherboard replaced (curious cat + high workbench + laptop = pain). I got it back, it booted up just fine. Got to Windows login, tried to move the cursor via the trackpad, and nothing. After hours of troubleshooting in Windows, I took the thing apart, only to discover that whatever technician had repaired my machine had neglected to plug everything in. . . So, after plugging in the system fan and mouse, I reassembled my computer and went merrily on my way.

    Gotta love Dell’s workmanship.

Leave a comment

Leave a Reply

Your email address will not be published.

More Insights

View All